Technical and network requirements for NextGen

VizZle NextGen is optimized for the following browsers:

  • Chrome (latest version)
  • Safari (version 9 or higher)
  • Edge (Chromium-based version)

For the iPad app we recommend iOS 10 or later.

 

If you're behind a network firewall or proxy, please speak with your IT support about white-listing the following URLs:

https://*.govizzle.com

https://*.monarchteachtech.com

https://*.monarchtt.com

https://*.responsivevoice.org

 

Click here to learn how to set up Vizzle access through Clever SSO.

Have more questions? Submit a request

0 Comments

Please sign in to leave a comment.
Powered by Zendesk